AWUS036ACM Alternative Linux Driver Information

We have become aware of an alternative community-driven Linux driver developed for the Mediatek MT7612U chipset. We tested it recently with our AWUS036ACM and it works quite well.

Credit and thanks from us goes to the contributors of the following GitHub repositories:
– OpenWrt mt76 (https://github.com/openwrt/mt76)

We will share our testing instructions and steps here. Hopefully it helps interested Linux users. Here we have used Kali Linux 2018.3 for reference:

Step 1:

First boot into Kali Linux 2018.3, login as superuser “root”, and open the terminal.

Step 2:

Run the command to install headers files required for driver compilation.

# apt-get install linux-headers-amd64

Step 3:
Run the command below to download driver source code:

# git clone https://github.com/cyangy/A6210-mt76x2u_Ubuntu.git

 

 

Step 4:
Enter the driver source directory and run the command below to compile and install:

# cd A6210-mt76x2u_Ubuntu
# make install

 

Step 5:

After driver installation, we can plug in our AWUS036ACM USB WiFi dongle. Type the command `dmesg`. It may show results like this:

 

Done:
We have finished the driver installation successfully and can use it normally

Note: We also tested with the Ubuntu 17.10 with kernel 4.13. The brief steps we used are:

# apt-get install build-essential git
# git clone https://github.com/cyangy/A6210-mt76x2u_Ubuntu.git
# cd A6210-mt76x2u_Ubuntu
# git checkout fc573e6
# make install

* remember to specify the  “fc573e6” version to get past the compile error. Our testing results are:

 

 

 

Warning: The driver is not the one provided to us by the chipset manufacturer which we give to customers. So the usual warning: Use at your own risk. We cannot be responsible. We will update this post if we have newer, better information.

Author: ALFA Network Inc.

ALFA Network Inc. https://www.alfa.com.tw

41 thoughts

  1. If you use totally New Mac OS X 10.13, it will not work, it only work when you use Mac OS X 10.12 to upgrade to Mac OS X 10.13. Sorry for any inconvenienceWe will try to solve this problemThank you

    Like

  2. I just installed the new driver (12-05-2017) and while the wireless utility shows up right after the install (before restarting), when I restart it won't work.Please update it.

    Like

  3. Hello, I installed the newest 2017/12/05 and rebooted and it has the same behavior as the previous one – the small icon appears in the top right corner but it will not show the Wireless Utility from there or from clicking the icon in Applications. I tried shutting it down in Activity Monitor and reopening from the Applications folder, and the icon reappears but same response. I am using macOS 10.13.1 that was upgraded from the previous version, not a new install.

    Like

  4. I own one of these and it works great with one exception …. there is no way to input vpn settings im on the road 5 out of 7 days a week working az a range extender is great but i want to see the option for vpn setting on here and working that would make things so much better considering i use this for work

    Like

  5. Thanks, Kali seems content with this solution as well. Both 2.4 & 5 GHz bands in fact!root@roguelaptop01:cat /proc/versionLinux version 4.18.0-kali3-amd64 (devel@kali.org) (gcc version 7.3.0 (Debian 7.3.0-30)) #1 SMP Debian 4.18.20-2kali2 (2018-11-30)

    Like

  6. look,i have the alfa AWUS036ACM, i have dual boot : windows 10 and kali linux.When i am on windows 10, the alfa modules turns on,works properly… And if someone payed attention, there's a little led on the alfa module , that when i am on Kali Linux, and after had plugged in the module,the led won't turn on and my kali linux, doesn't show an added wlan module , and , my kali linux machine (on windows) did the same thing … so pls, if someone has a notice so it can work thank you

    Like

  7. I have the Awus036acm but my case is that when I run the ifconfig or ifconfig 8t doesnt show that there is a presence of any connected wireless adapter where as if I check on devices it shows there. I need help please

    Like

  8. Have being battling this since morning…still on it…really need help….I have ran installed the CD installations and done all necessary things I need to yet…it doesnt show its presence when you run ifconfig nor iwconfig

    Like

  9. The only linux driver, which is this one, isn't working for me. Im guessing latest kali kernel isn't compatible.Make install goes through, 4 modules are installed into /lib/modules/4.19.0-kali5-amd64/kernel/drivers/net/wireless/Upon plugging in dmesg logs:[ 146.637886] usb 3-2: new SuperSpeed Gen 1 USB device number 2 using xhci_hcd[ 146.659424] usb 3-2: New USB device found, idVendor=0e8d, idProduct=7612, bcdDevice= 1.00[ 146.659427] usb 3-2: New USB device strings: Mfr=2, Product=3, SerialNumber=4[ 146.659429] usb 3-2: Product: Wireless [ 146.659430] usb 3-2: Manufacturer: MediaTek Inc.[ 146.659432] usb 3-2: SerialNumber: 000000000[ 146.810287] usb 3-2: reset SuperSpeed Gen 1 USB device number 2 using xhci_hcd[ 146.834770] mt76x2u 3-2:1.0: ASIC revision: 76120044[ 146.855252] mt76x2u 3-2:1.0: firmware: failed to load mediatek/mt7662u_rom_patch.bin (-2)[ 146.855256] firmware_class: See https://wiki.debian.org/Firmware for information about missing firmware[ 146.855258] mt76x2u 3-2:1.0: Direct firmware load for mediatek/mt7662u_rom_patch.bin failed with error -2[ 147.467770] mt76x2u: probe of 3-2:1.0 failed with error -2[ 147.467814] usbcore: registered new interface driver mt76x2u[ 205.905707] usb 3-2: USB disconnect, device number 2I tried 3 different commits of this make repo, aimed at 3 different commits in driver repo and it's always the same. I also tried restarting pc after each install.My kali info… Linux cKali 4.19.0-kali5-amd64 #1 SMP Debian 4.19.37-5kali1 (2019-06-20) x86_64 GNU/Linux@Mat would you have any clue what is to be done? This is the only driver I can find for linux and it doesn't work!!I will try with ubuntu with newer 5.+ kernel in a bit, but it's definitely not looking good.

    Like

  10. Another thing I noticed, in drivers modules there is a folder,\”/lib/modules/4.19.0-kali5-amd64/kernel/drivers/net/wireless/mediatek/mt76\”with modules \”mt76.ko mt76-usb.ko mt76x0 mt76x2-common.ko mt76x2e.ko mt76x2u.ko\”and all of them, besides mt76x0 have install date of 20 Jun. Since that is the kernel update date, I belive drivers were included with kernel, but not working with awus036acm. Is it possibe that kernel drivers prevent installed drivers from this article to not work? I don't know enough to debugg it myself

    Like

  11. I tested AWUS036ACM with5.0.0-20-generic #21-Ubuntu SMP Mon Jun 24 09:32:09 UTC 2019 x86_64 x86_64 x86_64 GNU/LinuxNewer kernel has slightly newer driver, that works out of the box, but not very good. Led doesn't work, iw list shows some weird numbers, bandwidth is low..I tried to install mentioned driver again, this time it loads when usb is inserted but has some missmatch variables and ultimately doesn't work either. I tried different commits too.I tried https://github.com/jeremyb31/mt7612u too, but it wouldn't install.The way I see it, it's an absolute loss.

    Like

  12. Driver compatibilities depend on Linux distributions and kernel versions. What's your distribution and kernel version? BTW, this dongle's chipset(MT7612U) has was officially supported by Linux kernel since 4.19. You could also try newer kernel if it is easier way for you.

    Like

  13. Your feedback and sharing are great.I did some quick test on my NB with Archlinux and 5.0.2-arch1-1-ARCH kernel. The `dmesg` log was below:[1553286.416688] usb 2-6: new high-speed USB device number 55 using xhci_hcd[1553286.557793] usb 2-6: New USB device found, idVendor=0e8d, idProduct=7612, bcdDevice= 1.00[1553286.557796] usb 2-6: New USB device strings: Mfr=2, Product=3, SerialNumber=4[1553286.557797] usb 2-6: Product: Wireless [1553286.557798] usb 2-6: Manufacturer: MediaTek Inc.[1553286.557800] usb 2-6: SerialNumber: 000000000[1553286.686933] usb 2-6: reset high-speed USB device number 55 using xhci_hcd[1553286.829930] mt76x2u 2-6:1.0: ASIC revision: 76120044[1553286.859250] mt76x2u 2-6:1.0: ROM patch build: 20141115060606a[1553287.017400] mt76x2u 2-6:1.0: Firmware Version: 0.0.00[1553287.017402] mt76x2u 2-6:1.0: Build: 1[1553287.017403] mt76x2u 2-6:1.0: Build Time: 201507311614____[1553287.797001] ieee80211 phy8: Selected rate control algorithm 'minstrel_ht'[1553287.816999] mt76x2u 2-6:1.0 wlp0s20u6: renamed from wlan0I ran `iperf3` to test WiFi speed. It can reach 76.8 Mbps download speed and 75.2 Mbps upload speed, but ti sometimes also slow down to 13.2 Mbps DL and 13.2 Mbps UL.LED didn't light up as you found. I tried other MT7612U related repository before, but didn't success at all, only mt76 driver works on my NB.

    Like

  14. Thanks, for replying 🙂 If I understand correctly you tested drivers that came with kernel? Same as my new ubuntu kernel findings, they aren't working well. Bandwidth is unstable, only two supported modes. I also tested with arm processor and older kernel also, but I did not manage to compile drivers there.It really isn't looking well, considering https://www.aircrack-ng.org/~~V:/doku.php?id=faq suggests this wifi device. I might just return it instead of waiting years for drivers to be ready 😦

    Like

  15. That's true.I tested driver cam with kernel. AWUS036ACM with mt76 driver is not perfect for now, led doesn't light up, and sometimes not as stable as expected.We believe it will be getting better. mt76 driver is still actively maintained by open source developers, they really did great job and keep improving it.However, as you said, user may not wait so long. Changing wifi adpater would be an easier way to save your time.BTW, I found you mentioned Kali and ARM(with RPi?).If you are still interested in other ALFA's products, maybe you can give AWUS036AC/AWUS036ACH a try.Kali's aircrack-ng's driver support it well. (https://github.com/aircrack-ng/rtl8812au), and Kali's RPi image support it out-out-box for now.Hope it helps~

    Like

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Google photo

You are commenting using your Google account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

Connecting to %s